No components marked as affected
Resolved
All GCP cluster creation issues have been resolved
Identified
Launching new GCP clusters in us-central1,us-east4 and europe-west4 is currently impacted by an ongoing upstream provider ongoing incident.
Already running clusters are unaffected by the incident and remain healthy.