Resolved
Between 11:49 PM PDT on October 19 and 2:24 AM PDT on October 20, AWS experienced increased error rates and latencies for AWS Services in the US-EAST-1 Region. This has now resolved and service has been restored.
Investigating
Amazon Web Services has reported increased error rates and latencies impacting multiple services in the region. We have applied initial mitigations and we are observing early signs of recovery for some impacted AWS Services.