Account creation is now working as expected.
Resolved
Identified
Users cannot create new accounts for Redpanda Cloud.
Investigating
Redpanda is aware of and investigating a problem that may be impacting users of our cloud platform.